Is it possible to use UNC paths in boxstarter.config?

Sep 11, 2013 at 4:21 PM
Edited Sep 12, 2013 at 4:31 PM
I've set up a UNC path based local chocolatey repository on a fileshare.

I've tried to add:
When I try to run Invoke-BoxstarterBuild nothing happens.
Removing the element fixes the issue
Sep 11, 2013 at 6:29 PM
After changing the config file, you need to reimport the boxstarter.chocolatey module for the new setting to take effect.

That does not seem like an ideal user experience to say the least. In the next couple days I'll address this so that Set-BoxstarterConfig refreshes the module-wide $Boxstarter.LocalRepo setting.
Sep 12, 2013 at 4:20 PM
Actually I'm running this on a teamcity build agent and if I use the localrepo element in boxstarter.config this way Invoke-BoxstarterBuild does nothing.
I've made the boxstarter installation portable/part of the source tree so it's supposed to be imported every time I run it.

However, since you say it should work, I'll try it again.

Regards, Daniel
Sep 13, 2013 at 6:20 AM
What is the output of invoke-BoxstarterBuild?
Sep 13, 2013 at 12:26 PM
There is no output shown at all in my teamcity build log but there might be an error code that I haven't caught. I'll see if I can catch that in someway.
Sep 13, 2013 at 12:28 PM
As you can see in my other post, adding an UNC path to LocalRepo in boxstarter.config works with boxstarter.bat.
Sep 14, 2013 at 7:15 AM
The fact that nothing is output would indicate that the share is accesible but that Boxstarter thinks there is nothing to build. Boxstarter expects the directory structure to look like:
You would see nothing if there were no directories below "share". For Example if LocalRepo was \server\share\pkgA, that would output nothing.

In the next release I will make sure that it at least outputs the directory it is scanning like:

"Boxstarter: Looking for Package directories below \server\share"

And then have it report "no directories found below \server\share" if there are none.

Does this match your scenario?
Sep 16, 2013 at 12:00 PM
Ahem... Very stupid me. I guess that I should learn to read more carefully...

The proximity to the ChocolateyPackage, ChocolateyRepo, NugetSources elements somehow made me assume (a bad thing ;) that LocalRepo could be used to point out a local chocolatey repo. Now I totally understand why it didn't work.

Very well...