Error when attempting to install package via internally hosted server

Mar 11, 2014 at 6:41 PM
I have read over most of the documentation but am a bit new to all of this. I have a ProGet server that hosts nuget packages internally. When I attempt to run the installation of a test package via the URL method (or the cmd method) like so:

http://boxstarter.org/package/url?http://ourserver:81/feeds/default/testpackage

The complete dialogue exhibited in the command prompt is as follows:

Boxstarter: Installing package http://win8scripting:81/feeds/default/testypackag e Boxstarter Version 2.3.24
(c) 2014 Matt Wrock. http://boxstarter.org

Please type CTRL+C or close this window to exit Boxstarter if you do not want to
risk a reboot during this Boxstarter install.

Boxstarter may need to reboot your system.
Please provide your password so that Boxstarter may automatically log you on.
Your password will be securely stored and encrypted.
Autologon Password: ********
Autologon Password: ******
Boxstarter: Succesfully authenticated password.
Boxstarter: Disabling Automatic Updates from Windows Update
Boxstarter: Chocolatey not instaled. Downloading and installing...

Calling 'C:\Chocolatey\chocolateyinstall\nuget.exe pack temp_BoxstarterPackage\t
emp_BoxstarterPackage.nuspec -NoPackageAnalysis'.

Attempting to build package from 'temp_BoxstarterPackage.nuspec'.
Successfully created package 'C:\Users\root\AppData\Local\Apps\2.0\VN85P1L8.AJM\
B0CRKWQ0.RXC\boxs..tion_9b0d113b5eadff54_0002.0003_782bae5075bd89fb\BuildPackage
s\temp_BoxstarterPackage.1.0.0.nupkg'.

Boxstarter: Created a temporary package temp_BoxstarterPackage from http://win8s cripting:81/feeds/default/testypackage in C:\Users\root\AppData\Local\Apps\2.0\V
N85P1L8.AJM\B0CRKWQ0.RXC\boxs..tion_9b0d113b5eadff54_0002.0003_782bae5075bd89fb\
BuildPackages
  • Boxstarter starting Calling Chocolatey to install temp_BoxstarterPackage. This
    may take several minutes to complete...
    Chocolatey (v0.9.8.23) is installing 'temp_BoxstarterPackage' and dependencies.
    By installing you accept the license for 'temp_BoxstarterPackage' and each depen
    dency you are installing.
    ______ temp_BoxstarterPackage v1.0.0 ______
Write-Error : Package 'temp_BoxstarterPackage v1.0.0' did not install successfu
lly: At C:\Chocolatey\lib\temp_BoxstarterPackage.1.0.0\tools\ChocolateyInstall.
ps1:19 char:406
  • ... ipt">$(function(){$('body').append('<scri'+'pt type="text/javascript" src
    ="http: ...
  • ~
Missing name after function keyword.
At C:\Chocolatey\lib\temp_BoxstarterPackage.1.0.0\tools\ChocolateyInstall.ps1:1
9 char:407
  • ... pt">$(function(){$('body').append('<scri'+'pt type="text/javascript" src=
    "http:/ ...
  • ~
    An expression was expected after '('.
    At C:\Chocolatey\lib\temp_BoxstarterPackage.1.0.0\tools\ChocolateyInstall.ps1:1
    9 char:408
  • ... t">$(function(){$('body').append('<scri'+'pt type="text/javascript" src="
    http:// ...
  • ~
    Unexpected token '{' in expression or statement.
    At C:\Chocolatey\lib\temp_BoxstarterPackage.1.0.0\tools\ChocolateyInstall.ps1:4
    7 char:39
  • <span class="version">Version <span id="ProGet_Version">2.2.13 (Build
    4) ...
  • ~
    The '<' operator is reserved for future use.
    At C:\Chocolatey\lib\temp_BoxstarterPackage.1.0.0\tools\ChocolateyInstall.ps1:4
    7 char:81
  • ... .2.13 (Build 4)</span></span>
  • ~
    The '<' operator is reserved for future use.
    At C:\Chocolatey\chocolateyinstall\functions\Chocolatey-NuGet.ps1:90 char:17
  • Write-Error "Package `'$installedPackageName v$installedPacka
    geV ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
    • CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
      tion
    • FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
      n,Write-Error
Finished installing 'temp_BoxstarterPackage' and dependencies - if errors not sh
own in console, none detected. Check log for errors if unsure.
  • Boxstarter finished Calling Chocolatey to install temp_BoxstarterPackage. This
    may take several minutes to complete... 00:00:03.6756784
    True
    Boxstarter: Enabling Automatic Updates from Windows Update
    Type ENTER to exit:
The powershell script associated with the package literally only calls notepad.exe to run.

Any ideas on where I might look next?
Editor
Mar 12, 2014 at 8:25 AM
Hey,

I am going to take a stab at this, but bear in mind, I could be wrong, so wait for Matt to confirm :-)

By doing what you are doing, you are essentially telling Boxstarter to go to the URL that you have provided, and in that location there will be a text file, and then it will take that text file, do the work of wrapping that text file into a Chocolatey/Boxstarter package, and then install the package. This process is described here:

Web Launcher

However, what you are trying to do is provide a URL to a Chocolatey/Boxstarter feed, where a package with a particular name is located. Try this:
http://boxstarter.org/package/fiddler4
This will use the Boxstarter URL to go out to the internet and try to find a package called fiddler4. This will work, because the fiddler4 package exists on Chocolatey.org. Boxstarter will then grab this package, download it locally, and then execute the install. You can do something similar by passing in a URL to a gist on Github, as described in the article above, however, that is not what you are currently doing, although a perfectly valid route.

What I think you want to do is to instead use the command:
Install-BoxstarterPackage textpackage
However, this will still not work out of the box, because your package "textpackage" doesn't exist anywhere that Boxstarter knows about. If you do:
Get-BoxstarterConfig
You will see that NugetSources is currently set to:
http://chocolatey.org/ap/v2;http://www.myget.org/F/boxstarter/api/v2
These are the two locations that Boxstarter will look for a package with a particular name. If it doesn't find it, it will report that package can't be located. So what you could do instead, is one of two things...
  1. Push your package to Chocolatey.org
  2. Push your package to the Boxstarter MyGet Feed
  3. Add your own feed to the NugetSources
The first two are unlikely to be what you want, but I think the third is.

You should be able to use:
Set-BoxstarterConfig
To update the NugetSources property to include your feed which is http://ourserver:81/feeds/default and then run:
Install-BoxstarterPackage testpackage 
Hope that helps!

Gary
Marked as answer by gep13 on 3/14/2014 at 6:33 AM
Mar 12, 2014 at 4:03 PM
Gary, that makes sense. Thank you very much for your help! I'll try adding my own internal source and report back.
Mar 14, 2014 at 2:19 PM
Using the method you outlined above worked for me. I was able to call Install-BoxstarterPackage testpackage and launch the package install successfully. Thanks again!
Editor
Mar 14, 2014 at 2:33 PM
Hey,

Glad to hear that you got it working! :-)

Gary